Server crash on startup


  • Hey there.

    I am rather new to this game and recently gotten a server.
    Since the new update 7.5.0 the server keeps on crashing on startup.
    And there is little to nothing that I can do about.
    Ive contacted the server host about it and this is the answer I got from them:

    "Hello DesertFox,

    Your game application got an error :

    [06:31:37] Error in SkidSteerObject at 19: The namespace 'Eco.Mods.TechTree' already contains a definition for 'SkidSteerObject' (CS0101)

    Unhandled Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Exception: Error in SkidSteerObject at 19: The namespace 'Eco.Mods.TechTree' already contains a definition for 'SkidSteerObject' (CS0101)

    at Eco.ModKit.RuntimeCompiler.HandleCompilerError(CompilerResults results)
    at Eco.ModKit.RuntimeCompiler.LoadOrCompileMods()
    at Eco.ModKit.ModKitPlugin..ctor(ManualResetEvent doneEvent)
    --- End of inner exception stack trace ---
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, StackCrawlMark& stackMark)
    at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
    at System.Activator.CreateInstance(Type type, Object[] args)
    at Eco.Server.PluginManager.AddPlugin(Type pluginType, Object[] p)
    at Eco.Server.PluginManager..ctor()
    at Eco.Server.Startup.Start(String[] args)
    at Eco.Server.MainClass.Main(String[] args)

    Best regards,"

    I dont know what I can do about it, but if you need the error message that I get upon joining the server then its below here:

    "<size=150%>Connection Failed</size>

    Failed to establish connection - no response from remote host

    Log File:
    Initialize engine version: 2017.4.2f2 (52d9cb89b362)
    GfxDevice: creating device client; threaded=1
    Direct3D:
    Version: Direct3D 11.0 [level 11.1]
    Renderer: NVIDIA GeForce GTX 1080 (ID=0x1b80)
    Vendor: NVIDIA
    VRAM: 7985 MB
    Driver: 23.21.13.9124
    Begin MonoManager ReloadAssembly

    • Completed reload, in 0.124 seconds
      <RI> Initializing input.

    <RI> Input initialized.

    <RI> Initialized touch support.

    UnloadTime: 0.715368 ms
    Setting up 4 worker threads for Enlighten.
    Thread -> id: 1b3c -> priority: 1
    Thread -> id: 9e4 -> priority: 1
    Thread -> id: 2cd8 -> priority: 1
    Thread -> id: 380c -> priority: 1
    The referenced script on this Behaviour (Game Object 'Camera') is missing!

    (Filename: Line: 1758)

    The referenced script on this Behaviour (Game Object 'ClauseDropdown') is missing!

    (Filename: Line: 1758)

    Disconnected from server.

    (Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)"

    Cheers.


  • 2
    Posts
    253
    Views
    Log in to reply


  • Please post bug reports here: https://github.com/StrangeLoopGames/EcoIssues/issues

    Thanks!

    Shay McLean
    Community Manager
    Strange Loop Games


2
Posts
253
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!