[Server Bug] Server crash when players visit website through game.


  • Whenever any of the users on my server click to vote on an election or visit the webserver hosted by the game the server becomes unresponsive and crashes.

    It seems to happen every time that someone visits the website.
    Server was installed through Steam. Map size is 200x200. ParallelWorldObjectTicks is set to True.

    Exception
    LiteDB.LiteException: Timeout. Database is locked for more than 00:01:00.
    at LiteDB.LockService.Write()
    at LiteDB.LiteEngine.Transaction[T](String collection, Boolean addIfNotExists, Func2 action) at LiteDB.LiteEngine.Insert(String collection, BsonDocument doc, BsonType autoId) at LiteDB.LiteCollection1.Insert(T document)
    at Eco.Simulation.WorldLayers.WorldLayerStats.<>c__DisplayClass0_0.<CollectStats>b__0(Species species)
    at Eco.Shared.Utils.EnumerableExtensions.ForEach[T](IEnumerable1 enumeration, Action1 action)
    at Eco.Simulation.WorldLayers.WorldLayerStats.CollectStats()
    at Eco.Simulation.EcoSim.CollectStats()
    at Eco.Core.Plugins.TickTimeUtil.TimeSubprocess(Action func)
    at Eco.Simulation.EcoSim.DoTick(TickSample tick)
    at Eco.Simulation.EcoSim.Run()
    at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart(Object obj)


  • 2
    Posts
    655
    Views
    Log in to reply


  • I've resolved the crashing issue, apparently TickContinuously was set to False, setting it to true fixed the crashing. However, whenever a player visits the website the server becomes laggy/unresponsive until they close the webpage.


2
Posts
655
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!