Can't start the game :/


  • Hi, i just updated my game to the 7.2 and 7.2.1 ect... updates, but after the 7.2 the game won't launch in my computer, it start but stay a black screen without anything else, can you help me ?

    image.png

    befort the update, i coud play without any problems, i tried to reinstall my graphic driver but that didn't work.


  • 15
    Posts
    2660
    Views
    Log in to reply


  • Someone posted an interesting behavior. When he reinstalls the game it works just the first time. Then crashes every time afterwards. Could be hinting to a solution.

    Here is my experience with this problem. I played on 2 powerful PCs no problem. This black/gray screen displays on a PC with only an integrated graphics card. Furthermore If I have little unused RAM, it crashes after a minute. If I have plenty of ram, it just stays on the black screen.



  • I have exactly the same problem, just bought the game on steam since it sais that it supports integrated graphics (Minimum Graphics: NVIDIA GeForce GT 440 or AMD Radeon HD 5850 or Intel HD Graphics 4000 with 512 MB)

    I tried it on my Lenovo ThinkPad P50 with NVIDIA Quadro M1000M graphics card (it also has Intel(R) HD Graphics 530 as second GPU, ). In the task manager I can see how the NVIDIA GPU is cooking at 100% while ECO does the black screen thing. I do get a fancy cursor though and sound is running in the background. Sometimes I even get responsive sounds when I hit enter, so I would guess the game is running in the start screen or something, I just can't see it.

    The 16GB RAM I have are at about 41% for the whole system (about 1.5GB for ECO).

    CPU (Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz) is at 100% at the beginning while the EcoServer is doing what I would call the initial phase as far from what I've read. Afterwards CPU usage for ECO falls back to 33%.

    Unfortunately I'm running Windows 10, and I must admit that I did not research on problems with that before posting this. I will do that though now.



  • @snooks87 said:

    hey guy !! first of all im sorry about this broken english XD, i got this problem too when i've tried to play in solo , then i tried to go in C:\Program Files (x86)\Steam\steamapps\common\Eco\Eco_Data\Server on the EcoServer app right click run as admin there is a window (black) let it generate the server when its done launch the game and try to launch your solo game it should work now. i got the game on steam since maybe 3 day. since we cant link it to the eco web site i guess the matter can come from there . i dont know if your problem was about to play in solo but it can help other to make it work

    unfortunately this approach didn't work for me. I forgot to mention that earlier. I'm new to early access games, looks like fun so far ;-)



  • @dc_50168 This is exactly my problem



  • I went through it again. I can start the server itself from the above mentioned location. I can run it as administrator or without, it always successfully starts a server.I also found a log file in the ECO server directory that states that the server "Initialization finished in 107.659,4ms". That and the fact that I can then take a look at all settings and stuff for the server (even map layers and so on) shows that the server itself is running.

    Seems to be a GUI related problem (or however you would say that in gaming language). Somethings off with the GPU stuff. Last time I had a problem like that was with the horrible NFS Most Wanted reboot from 2012, downloaded from Origin. Worst 5 bucks I've ever spent. Turns out it doesn't support anything that has more than one GPU in it. (google: NFS most wanted will not launch)

    That were the most annoying 2 afternoons+evenings I ever spent on troubleshooting a game and the first time it absolutely did not run. F*** EA for not caring at all.

    I'm drifting off. sorry.



  • Hi everyone, I'm also having this problem where it loads a black screen, a cursor and sound effects but nothing else. I find it really strange because I played it fine a few days ago through steam and months ago before it was on steam. This is so frustrating I just want to carry on playing the game but I can't even reach the main menu. Also it's launching fine on my brothers computer so what the hell? :(



  • As mentioned in this conversation, we kind of hope that it's connected to the recent update (7.2, 7th of march). Maybe the next update will solve this.

    If a MOD should be reading this: maybe there's a way to put this thread in the right Category? To give it a bit of highlighting... From General to something more fitting...



  • Found a solution, this forum category doesn't really seem to be read when it's about bugs. The official bug report way goes via github:
    https://github.com/StrangeLoopGames/EcoIssues/issues/4834

    What's been working out for me is the following from the github thread:

    I went into Nvidia Control Panel. This is where I changed "Aspect ratio" to "No scaling" on the Adjust desktop size and position page (with "perform scaling on Display").

    With my setup it was also connected with the following:
    https://forums.geforce.com/default/topic/547415/nvidia-control-panel-missing-options/

    ...which was caused by my laptop having 2 GPUs as described before. I had to deactivate the "hybrid graphics mode" in the BIOS to "discrete mode", so my laptop would exclusively work with my nvidia quadro M1000M. After I did that I could finally deactivate the "Aspect Ratio" setting.

    And voila, it finally works!



  • I just downloaded a new update and it seems to have fixed it - I'm so happy!



  • Also would like to know why my other post was downvoted? I don't see what's wrong with it?


15
Posts
2660
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!